ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org

Announcing updates in auv_msgs

TL;DR: A new version of auv_msgs has been released to Indigo, Kinetic and Lunar. Broke message API to fix names.

For more details see the changes here
Feel free to open PR-s if you’ve got something to add :slight_smile:

We’d also like to welcome Ignacio to the maintainers team!

1 Like

I don’t know if this fits here, but isn’t auv_msgs a very broad non-name? It is broad because this doesn’t tell the function. It’s not like they can be used only for auv and not uav.

The messages should be called navigational_msgs or something similar (this is an unsolicited opinion) :smile:

Frankly, I don’t even agree with using all these 3-4-letter acronyms that are so popular in the underwater domain: AUV, ROV, UUV, UVMS and friends.

…but they been named before me and everyone refers to it that way. Same with this package. It’s been around in different underwater robotics labs for many years, it’s only recently that we made a binary release of it :slight_smile: