ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A

[Beta Test] DYNAMIXEL Wizard 2.0

Happy belated New Year!

We hope you are having a great start of the year.

Here’s a good news for all of you especially advanced users and Linux users.
All new DYNAMIXEL Wizard 2.0 is about to be released, so we’d like you to try it and tell us what you think.
The DYNAMIXEL Wizard 2.0 supports Linux and Windows, and going to support OS X as well in the near future.

DYNAMIXEL Wizard 2.0 comes with various advanced features that will allow users to get the most out of DYNAMIXEL.

Below is the list of advanced features “currently” implemented in the software.

  1. Graph plotting feature : User can select Control Table items to plot data on the graph
  2. Packet Monitoring & Generation : User can easily generate packets and log TX/RX packets to analyze
  3. DYNAMIXEL Diagnosis : Enhanced diagnosis helps to figure out the problem of DYNAMIXEL.
  4. Enhanced Firmware Updates : Multiple DYNAMIXEL with different ID can be updated at the same time.
  5. Multi Baudrates, Ports are supported.

Please refer to the below eManual for more information.

Software can be downloaded at below download link.

Please feel free to report any bugs or issues.

Well, on windows, it only downloads a file without file extension. This file cannot be run even when I rename it to have exe or msi extension…

You might have downloaded Linux version.
I just downloaded windows version and which has an .exe extension on it.

Ah, you’re right, I’ve probably misclicked :slight_smile: Thanks

Is this compatible with the U2D2 usb-serial adaptor sold by Trossen?

(I am also back-feeding 12V with a power hub)

I’ve tried to get the wizard2 software to work on both Linux & Windows 10 with no luck.

I also downloaded the RoboPlus software and DynamixelWizard1.0 it is not working on Windows10

I tried scanning 1.0 & 2.0 and every possible Baud rate.

I also have an Arbotix-M board, and I can use that to talk to the servos, so I know that the servos work.

Hi @tomsepe,

ROBOTIS officially distributes U2D2 for DYNAMIXEL and it should work well as long as you have correctly installed the driver(usually Windows installs it automatically)
Could you elaborate more on “what did you do and how did it fail” part?
Video or picture would be very helpful in this case.

I think I might be experiencing hardware failure. the device was working fine yesterday. With dynamixelwizard2 the scan feature works and the lights blink in the U2D2 but it never finds a servo.
And when I try to run dynamixel_workbench_single_manager package I’m getting “incorrect status packet”

When scanning for DYNAMIXEL do you see both TX(green), RX(blue) led on U2D2 blink?
What DYNAMIXEL do you use?
Also, go to Options menu and make sure that you are selecting correct COM port and baudrates.

Yes both lights blink but it never finds a servo. it doesn’t matter if I connect to an XM540 or and XM430. I purchased another U2D2 and it can see the servos so there is something wrong with this unit

It looks like there is an issue with the DPI setting in Qt.

A packet log to be able to view some amount of lines (10000?) of rx/tx packets for diagnostic/debugging purposes would make a great addition.