ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org

Error during running the devel job locally: Unable to connect to 54.183.65.232

Guys, I am trying to make a local build to verify some of my changes using the following instruction:

However the generated script devel_job_indigo_roscpp_core.sh can’t connect to 54.183.65.232 and I see the following error:

Hit http://archive.ubuntu.com trusty/main amd64 Packages
Hit http://archive.ubuntu.com trusty/restricted amd64 Packages
Hit http://archive.ubuntu.com trusty/universe amd64 Packages
Err http://54.183.65.232 trusty InRelease
  
Err http://54.183.65.232 trusty Release.gpg
  Unable to connect to 54.183.65.232:http:
Reading package lists...
W: Failed to fetch http://54.183.65.232/ubuntu/testing/dists/trusty/InRelease  

W: Failed to fetch http://54.183.65.232/ubuntu/testing/dists/trusty/Release.gpg  Unable to connect to 54.183.65.232:http:

W: Some index files failed to download. They have been ignored, or old ones used instead.

Failed to fetch

Reinvoke 'apt update' (10/10) after sleeping 25 seconds

Is the server temporarily unavailable?

Manually changing this generated IP to what ROS jenkins uses http://repositories.ros.org/ubuntu/testing helped to proceed with the task, but still not clear yet for me how this IP was generated when I followed the instruction.

The examples were using the default branch of the buildfarm config repo. This branch does no longer work since it references a test farm which is not available anymore. I just updated the examples to point to the production branch instead which is used by the official buildfarm and will continue to be available: https://github.com/ros-infrastructure/ros_buildfarm/pull/390

The README in https://github.com/ros-infrastructure/ros_buildfarm_config mentions the different branches but the information is bit “hidden” in the text and not easy to discover.

Thank you. Now it works.