ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org

intra_process_demo --> select timeout


#1

I’m new to ROS and definitely to ROS 2. Looking to use ROS in a new robotics product under development. I really like ROS 2 but have been struggling with video stuff for a couple of days.

Sorry if I’m posting this in the wrong place. Let me know the right place if this is wrong.

Dev environment is a VM under OS/X (10.13.6 on MacBook pro.) VM is running Ubuntu Bionic. I was running the VM under parallels 14, but ran into the issue that parallels STILL only supports openGL 1.2 --> so it might be good to warn folks that parallels is no good for ROS 2 development efforts. This meant that the viz2 stuff won’t work since it requires 3.2+. I did run the video “intra_process” demos under parallel’s no problem (other than being laggy.)

Purchased, downloaded and then rebuilt the world under VMware Fusion (11.0) Was able to run rviz2 – yea, but when I went back to re-test lag of intra_process I get a series of “select time” messages on the console. Eventually, a single image is display. I see my camera LED come on right away. Anyone else see this issue? Is it strictly related to “intra process” comms or something else?

A message like “select timeout” to mean invokes some kind of network issue, but I’m not sure what it could be. I tried fiddling with the network setup (NAT/Bridged/various configs) and I tested that network is good and that multicast is enabled on all interfaces. Still no joy.


#2

This kind of thing is best asked on answers.ros.org, see: https://wiki.ros.org/Support#When_something_fails

On my native machine the intra process demos run smoothly, but there are lots of reasons it might not perform as well in your setup (VM, host computer, network configuration issue, something else). So when you redo your question on answers.ros.org, consider providing more details like the exact console output (e.g. what exactly does this ‘select timeout’ message look like?) and how to reproduce it – ideally with a minimal example of how to reproduce the issue.


#3

Thanks. New here, just needed the pointer of where to post.