ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org

Issues with rtpsgen

I started with ROS 2.0 recently. After going through the initial basic steps, I thought of writing some test package. However when I add my workspace to eclipse (oxygen), it would report 7 build errors, ‘rtpsgen’ is missing required library: ‘lib/antlr-2.7.7.jar’. I tried installing the latest antlr library 4.5 however the error still persists. However it did not create any issues while creating an ament package or a normal build.

I would like to what sort of error is this?

rtpsgen is the code generator of FastRTPS. ROS 2 doesn’t use that tool so we have never tried to interact with it. You might want to ask your question on the upstream repo of FastRTPS.