ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A

New depth sensor, Orbbec Astra, call for testing

Thanks for the driver @tfoote !

I gave it a try but there is a lot of noise on the depth measurement,
compared to the openni2_camera driver.
comparison videos:

what is the best way of sharing the bag files with you?



here are the bag files taken with the openni2_camera and astra_camera drivers… enjoy.

note: we are using the model ASTRA S



I see three versions, the “Astra”, “Astra S” and the “Astra Pro”. They are even all the same price.

Can you be specific about which version you are targetting or will work best with the TurtleBot?

We are looking at the Astra for the TurtleBot. It’s spec is closest to the current default sensor - the Asus Xtion Pro Live.

Right now the Astra Pro’s high-res image stream is not available through OpenNI and hence not available for ROS with the current wrapper.

The Astra S could be used as well. Personally, I don’t see the few centimetres you get extra at close range worth for what you lose in range.


+1 Same problem as Procopio here. Heavy noise is around the borders.

Also rviz crashes when trying to view any image stream.


I tried the ROS driver with the Astra S (the short range model) and it was unusably noisy. The best way I can describe the point cloud is “blizzard in a glass pyramid”. As a sanity check, I tried using the standard SDK on my mac, and it was fine (although the data was definitely not nearly as good as a short range carmine). Has anyone had success with the Astra S and the ROS driver?

I wasn’t able to test their SDK on linux because the link to download that from their developer page goes to a 404 for a Dropbox file. Sketchy…

I believe you can get their modified OpenNI2 version from Github:

Thanks @bit-pirate, I’ll try that out.

I made an issue for the weird noise ad the edges of objects:

1 Like

For anyone interested, here are the openni drivers provided by orbbec:

There’s apparently an unreleased filter applied to the prebuilt binaries:

I’ve opened a ticket at:

1 Like

In case you haven’t seen we’ve successfully run the TurtleBot demo applications using the Astra on the TurtleBot.

Thanks for the Astra driver Tully. We have made some tests and despite the noise, it works well with the Turtlebot.

Hi folks, sorry if this is not the proper place to post.

I am having some disturbing issues with the Astra sensor. It seems that
after a couple of hours of usage, the pointcloud published starts to get
distorted, as if the camera is changing its roll. You can find more details

Did you have any similar issues when testing it with turtlebot??
Any ideas on how to address this issue?

Thank you,

Your question on the Orbbec forums is likely the right place to ask. I have not observed it but our demos are not especially sensitive to small roll angles to we might not have noticed.

Hi everyone,

I am a new user of turtlebot2. I got a problem on setting up the Astra sensor.

First, I failed to set up the video stream in this tutorials . The error is “uvc_get_stream_ctrl_format_size: Invalid mode (-51)”. Is there anyone got this problem, and could you please let me know how to solve it?

Second, when I cakin_make astra_camera, there is a error “/usr/bin/ld: cannot find -lOpenNI2Orbbec”. Can you please let me know how to fix it?

Thank you very much!


HI @ycx424,

Please ask debugging questions on

I’ll note that the tutorial you’re following looks to be for the TurtleBot2 with the Kinect and thus would not be expected to work with the Astra for anything specific to the camera such as setting up video streaming.

And your compile issue looks like it warrants a separate question. Please provide enough information to reproduce your problem when you ask your question, otherwise we will just be guessing what your problem is.

Hi tfoote,

Thank you very much for your quick reply. Regarding my second problem, I firstly download your released package from here. I successfully finished the first two steps. When I did “roslaunch astra_launch astra.launch”, there was a warning in the terminal.

Then, in rviz I cannot receive any data from the following topics:

Sometimes, there will be an error shown in the terminal that “Camera calibration file /home/turtlebot/.ros/camera_info/depth_Astra_Orbbec.yaml not found.”

Regarding the PointClound2, I can receive the data from /camera/rgb/camera/depth/points, but something is not working well, like this: the status error

And, I cannot receive data from topic: /camera/rgb/camera/depth_registered/points

There will be two warnings in terminal:

Thank you very much!

Please ask this question on following our Support guidelines: