ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org

ROS rosrun crash [Lunar Loggerhead] on Debian Stretch

Hi,

I’m facing this error after compilation or ros1: Lunar Loggerhead release. And create my own catkin package which builds successfully. On running the same using

rosrun $name $cmd $options ->

libgcc_s.so.1 must be installed for pthread_cancel to work

Anyone who has already found a workaround/fix? Please help. I’ve installed the necessary libgcc libs on my machine.

Thanks @sriramster for your report.
However we ask that you please ask questions on
http://answers.ros.org following our support guidelines:
http://wiki.ros.org/Support

ROS Discourse is for announcements and general interest discussions. ROS Answers
http://answers.ros.org/ provides a forum which can be filtered by tags to
make sure the relevant people can find and/or answer the question, and not
overload everyone with hundreds of posts.

Thanks!