ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org

Uploading large PCD file to tier4 maptool

Hello!

I am trying to use tier4 maptool to create vector map in ADAS format. But the online tool seems to limit the uploaded file size. I can upload a segment of the PCD file(~10mB), but not the entire map(~70mB). Anyone know how to deal with larger vector map building problem?

Thanks!

Have you tried increasing downsampling rate?

Thank you for replying! I wish to keep the details in the map, so I didn’t downsample the data. And in the future, I plan to deal with larger map (a few GB). That’s why I am looking for a long-term solution to make vector map.

I tried to increase downsampling rate to 1000, but it doesn’t work as well.

1000 might be too large.
I have succeeded uploading 125MB pcd with downsampling rate of 5, so I think the problem is not related to file size.
It may be that points are too small to be seen. You can press ctrl and ‘+’ to make points larger.
You could also try breaking your pcd into pieces rather than uploading one big file.