From this discussion and some thoughts mulling over in my head, @wjwwood would it be possible to change the get_parameter
method to be something like:
returnT get_parameter(args, args, bool declare_parameter=true) {
if (!has_parameter(...)) {
declare_parameter(...)
}
// normal
// get_param
// stuff
}
This way batteries included a get call is going to declare the parameter if not already? If not by default, having the default boolean not do it but have the option? The extra declaration I need to think about makes application-level code a bit less (elegant? readable? can’t think of the right word, but more “overhead stuff” to think about)
More than happy to submit a PR if that’s something agreeable.