ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org

Exclude Jessie from release, because of missing debian package

I have released an rqt package (rqt_multiplot), that depends on qwt, for ROS Kinetic. Unfortunately, the required qwt package (libqwt-qt5-dev) does not exist for Jessie. Now I get regularly a build error from the ROS buildfarm, that the Jessie package could not be build.

Is there a way to exclude Jessie from the release? Or do I have to remove the Kinetic release from the ROS distro? Or should I just live with the error mails?

There should be no reason to live with error emails. You can add your package to be blacklisted for Kinetic on Jessie. Just create a pull request against the ROS buildfarm configuration repository and add your packages here: https://github.com/ros-infrastructure/ros_buildfarm_config/blob/aaeb4258671d69c9fcdd23677dc45e0e728b82f0/kinetic/release-jessie-build.yaml#L14

1 Like