ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org

Payload size error with FastRTPS

What causes this error below? I see a lot of it (using a beta3 build from a week ago).

[RTPS_HISTORY Error] Change payload size of '5852' bytes is larger than the history payload size of '5000' bytes and cannot be resized. -> Function add_change

It’s coming from FastRTPS underneath; from perusing their code it looks to only be output if you’re using PREALLOCATED_MEMORY_MODE for the memory policy (e.g. here).

In rmw_fastrtps_cpp, the memory policy is explicitly set to PREALLOCATED_WITH_REALLOC_MEMORY_MODE (e.g. here). Are you customising the publisher/subscriber parameters yourself somehow? If so you’ll have to tweak some additional properties of the history cache.

I’m not intentionally using PREALLOCATED_MEMORY_MODE or any other non-default configuration for FastRTPS. By pub/sub parameters, you mean the QoS? I do customize that in a few places to enable durable data or to reduce the cache to try and keep data fresh.