ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org

Turtlebot3 - Joule stalled

Hi

Turtlebot 3 - Waffle … Joule - after installing Joule following the official documentation (Ubuntu 16.04 LTS) : everything works fine…problem: Joule stops working/running after approx 10min up - independently if operated on 12V/3A external power supply or with the battery provided with the Turtlebo3 kit. Logs don’t show any weird symptoms…

Any ideas? pls help…

Tnx in advance
ml

First thing to check, what is the temperature doing? Is the module overheating?

Also, does anyone know what the replacement for the Joule is, now that they are EOL?
Thanks :slight_smile:

Tnx Ilia for the hint…checking continously temp via /sys/class/thermal zones 0-7 - max. 45C … assuming that isn´t the root cause. Keep on digging…Best ml

…quick update: if you push the Power button (SW2) the “stalled” system recovers - even the Unix sessions…
…did I miss something here - kind of “sleep mode” / hibernation mode - some BIOS settings?

Interesting. Our bot was doing the same thing, with symptoms just like a software crash, so that’s what I assumed. Maybe it is going into a sleep mode of some sort.

I experience the same stalling that you describe. Have you managed to figure out a workaround?

Hey ashoed,

unfortunately not - tried all 3 BIOS versions, including the recommended #193 … same negative results.

Any luck on your side?

Best ml

Hi Michael,

Have you checked to see if there are settings within Ubuntu 16.04 for screensaver or power savings?

You should also check if you can update to the latest Linux kernel.

If you can type uname -r in the terminal on your Intel Joule and post the output, I may be able to load up my Intel Joule with your versions and check to see if I encounter the same issue.

Please keep us updated on any other efforts you may try.

Hi MyNameIsCosmo,

tnx for your support…some progress but not 100% done yet:

  • all updates based on “apt-get update” installed

  • HDMI not working - need to work with cli

  • uname -a:
    Linux turtle 4.4.0-1000-joule #0+joule21-Ubuntu SMP PREEMPT Thu Mar 16 14:46:45 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

  • following your hint “power saving” -> focussing on Ubuntu not Joule I did the following:

    sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target

-> unix processes will not get stopped/suspended anymore -> seems ok !
-> issue: every 30min the network manager gets a request to “sleep” (syslog) -> wifi connection goes down
-> can’t restart it automatically (service network-manager restart - nmcli network on - ifup -a)

No clue what causes the request for network manager to sleep…given that it is reproducible it seems a “feature”. Any idea how to tackle it? Seems I didn’t disable all “power saving” options (or what soever causes the nm shutdown…) - can’t find anything on the net that fixed it…

Every hint/comment welcome…

SOLVED: guess the “GUI” environment triggered the request to sleep after 30min - given that I run the Joule headless: disabling “Gnome” and “lightdm” did the trick - system up and running for hours (didn’t reverse the masking of sleep, suspend, hibernate, hybrid…)
Thank to all of you for the hints - Best Michael

2 Likes

Had the same issue, disabling gnome and lightdm did the trick! Thanks for sharing!