ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A

Waffle - HDMI no signal


I need help installing Ubuntu on TurtleBot3 Waffle.
I flashed Joule BIOS with version 193 (since 1J2 didn’t worked and seemed a lot of people had trouble with it).
Looked good :

  • Downloading BIOS
  • Clearing NvStorage…

However after that I can’t get any screen with micro HDMI-HDMI cable, still no signal.
I plugged power supply one openCR, keyboard, mouse and USB with Ubuntu on USB hub (which is connected to the Joule). All leds are green, plus the white/blue one.

Any suggestion ?

Hello r00t,
The below link is the method that worked for us to recover the joule.
It seems like the sequence of connecting and disconnecting cables do matter.

Thank you for your reply.

Tried everything, still can’t get it working.
First connecting type C USB, first connecting power supply, waiting 10min first boot before connecting HDMI, really everything. With both bios version 193 and 1J2. Even re-done exactly like in the video tutorial. Did it with two different Joule board (we got three of them), same thing.

Flashing is always fine, but can’t get that output working.

Anyone with an other idea ? (Hardware is fine, test moves worked)

According to McCool, sometimes specific monitors would not connect to the Joule.
Were you able to connect them with your current monitor before updating firmware?

Yep, it was working before updating…

I’m trying to reproduce the problem with my Joule and if I figure out what the problem is, I’ll share the solution for it.

Well, I took my chance installing directly the “Alternative Ubuntu for Joule” on a second Joule not flashed (since this way I did have acces to BIOS to boot on USB), and it works properly… (ROS install and turtlebot teleop working with no problem)
Seems weird 'cause there must be a reason the guide tells us to flash before doing it, but i am not complaining, it works.

I’ll keep trying make the first one work, and come back to you if I find a solution.

Thanks @WillSon

Hello r00t,

As far as I understand, BIOS 193 is required in order to install Ubuntu with a USB flash drive. Since it was one of requirements from Ubuntu Developer(, I didn’t doubt about updating the BIOS firmware.
At least you figured out your solution with the second Joule which is definitely a good news :smiley:
Please let me know if your second Joule has different BIOS version other than 193( so I can also try with the same version.

I was able to use joule-firmware-2017-06-26-1J2-public, specifically the debug bin file. My initial flash with the release file would not boot, nor display anything on screen. With the debug bin the board does run, although bootup times are very slow.

That said, the Joule board has proven to be unstable. I’m unsure on the root cause, be it BIOS, Ubuntu, or hardware, but since Intel has discontinued the board I don’t expect much in the way of software improvements. At present, I’ve swapped over to a Raspberry Pi, and have an Odroid XU4 which will eventually end up in the Turtlebot. I’ll go back to the Joule at some point, but it’s not a long term solution for development.

I got the same problem. The board was displaying the bios using hdmi but when I flashed bios version 193 I could not get hdmi output anymore. The flashing process didn’t give any errors. I also tried newer bios versions with same negative results.
I can connect to the board using serial connection. It seems to recognize the display when I execute xrandr -q. If I reboot the board it displays the whole boot sequence. These are the last commands before stopping:

[ 12.378641] Bluetooth: RFCOMM ver 1.11
[ 12.820056] HDMI HDA Codec ehdaudio0D1: HDMI: failed to get afg sub nodes
[ 12.827761] HDMI HDA Codec ehdaudio0D1: Failed in parse and map nid with err: -22
[ 12.836166] HDMI HDA Codec: probe of ehdaudio0D1 failed with error -22

It seems to be some sort of hdmi error. Any idea how to correct the issue?

Just a data point.
My Joule running 193 works with my Dell and Samsung monitors, with a generic type A to type A HDMI cable, and generic type A to type D adapter.
It won’t work with my Elecrow monitor, its included type A to C cable, and the above generic type A to type D adapter
It will work with my Elecrow monitor, its included type A to C cable, and a Rocketfish type A to D adapter.