ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org

Connect two usb2.0 cameras with autoware

Specifications: ROS Kinetic
ubuntu 16.04

Hi! I encountered a problem when I tried to connect two usb 2.0 cameras with autoware. It seems that autoware always just can recognize /dev/video0, which means autoware just can recognize one camera all the time. Is there someone who knows how to make autoware recognize another camera like /dev/video2 in my case? Autoware still can recognize one camera even after I deleted the contents of launch file in ros camera driver or the contents of uvc_camera.sh under /Autoware/ros/src/sensing/drivers/camera/usb, which makes me be stuck at the point where I do not know which file I should change so that two cameras can be used at the same time. I would appreciate it a lot if someone can help me figure this out. Please let me know if you need any details I left out here about this problem.

My ubuntu 16.04 system will show /dev/video0 and /dev/video1 when I just connect one camera to my computer. I guess that it is probably due to the microphone built in my usb camera.

USB Genric checkbox in Runtime Manager launches uvc_camera.launch under /Autoware/ros/src/util/packages/runtime_manager/scripts.

@BRIGHT_BULD Like you mentioned, the current launch script in runtime manager, and the one in the drivers section, are not designed to work with more than one camera.
However, you can instead use the launch file provided by the package, and select which device to use


From a terminal you might execute:
roslaunch uvc_camera camera_node.launch device:=/dev/videoX
and select the device you are interested to use.
Finally, you can find more details in the package documentation: http://wiki.ros.org/uvc_camera#Parameters
Hope this helps.

Thank you for your help. It works now after I changed a little bit of the launch file under util directory.