ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org

ROS2 command not recognized on MAC after installation

Hi

I have installed ROS Bouncy on MAC as indicated in the installation tutorial

However, after finishing everything ros2 command is still not recognized.
This is a screenshot.
05%20PM

I have sourced the ROS 2 setup file:
. ~/ros2_install/ros2-osx/setup.bash

I just skipped openslice and context support because I understood that eProsima’s Fast RTPS comes by default.

Did I miss something?

Thanks
Anis

I solved the problem by adding this command to .bash_profile

. ~/ros2_install/ros2-osx/setup.bash

Glad you figured it out!

However we ask that you please ask questions on http://answers.ros.org following our support guidelines: http://wiki.ros.org/Support

ROS Discourse is for news and general interest discussions. ROS Answers provides a forum which can be filtered by tags to make sure the relevant people can find and/or answer the question, and not overload everyone with hundreds of posts.

Thanks!

OK, thanks for the note, I missed that!