ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org

VirtualBox and Turtlebot 3. During RVIZ, unable to contact my own server at 10.0.2.15

I am using VirtualBox to run LINUX and ROS. The Turtlebot IP address is 192.168.3.68 but my virtualbox ip address is 10.0.2.15(this may be due to wired connection to my main OS, Windows)

I would like to use WiFi connection for communication between turtlebot and remote pc. Any idea how to resolve this issue? I’m just this close to achieving SLAM and navigation.

Thank you!

Your VM is not connected to WiFi network which is needed. Try to change VM network settings to Bridged Network.

I saw this problem multiple times. I am pretty sure that, as commented before, your VM is stablishing a private network with your windows. To check that:

In windows, go to the search box and type “cmd”. There type “ipconfig”. You will get the external IP of your PC, in your case, 192.168.x.x
In linux, in a terminal, the command “ifconfig” will return a different IP. If it is the same, the error is somewhere else…

To fix it, close your VM and go to its configuration in VirtualBox. If I remember well, it was right click on the name of the VM and configuration (I have no a VM here, sorry). In network there should be a drop-down liste. I think that by default is set to NAT (Network Address Translation). Change it to Bridget networking

Anyways, just change it there and open the VM again. Check if now the IPs are the same for your windows and your VM.

I have tried changing to bridged connection, then my WiFi(in VM) stops working altogether.
This is extremely, extremely, extremelyyyyy annoying. starts plucking some of my hair

Ok, let me see. I installed VM Virtual Box 5.2.6 and downloaded a ros indigo64bits VM from here: https://nootrix.com/downloads/#RosVM. 2.8Gb…men…To make it work it was also required the VM VirtualBox Extension Pack 5.2.6

Anyways, if I type in the “cmd” of Windows “ipconfig” I get the following information:
Ethernet-Adapter IPv4: 192.168.99.111 (numbers are a fake since I do not want to share my public IP)

I open the VM image, import the configuration as it comes and start it. If I type “ifconfig” I get an ethernet port with the direction 10.0.2.15.

I close the machine, right click on it. Settings > Network > Adapter1 > Attached to (change from NAT to bridget connection). I left the name of the adapter as it was, maybe you have to change it to use the WLAN adapter.
Oppening the VM again it shows me the following ip: 192.168.99.185
I can make “ping 192.168.99.226” without problem. This is an other machine where I have ROS installed.
I set up the environemnt for both…http://wiki.ros.org/turtlebot/Tutorials/indigo/Network%20Configuration

The configuration works…

By the way…shouldn’t this thing be posted in ROS answers?

It was: VirtualBox and Turtlebot 3. During RVIZ, unable to contact my own server at 10.0.2.15.

@Bbybo93: could you please close either this thread or the ROS Answers post?

Sorry, I made this post then I realized it was on the wrong platform, hence I went to answers.ros after.

I will most certainly be trying the methods.

Thank you guys so much.