ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org

[TB3] 64 Bit Gentoo Image

Hey all!

As you may have seen, there’s been some significant improvement with respect to Running ROS on Gentoo in the past few months. As such, I’ve compiled a 64-Bit Raspberry Pi 3 image with the necessary ROS components pre-installed!

Link to the image is here.

Info:

OS:

turtlebot@burger ~ $ uname -a
Linux burger 4.9.40-v8+ #1 SMP PREEMPT Thu Aug 3 13:18:43 PDT 2017 aarch64 GNU/Linux

Partitions:

  • /boot: 128M, vfat
  • swap: 512 M
  • /: 14 G, ext4

Compiler:

  • GCC 6.4.0
  • CFLAGS="-march=armv8-a+crc -mtune=cortex-a53 -ftree-vectorize -O2 -pipe -fomit-frame-pointer"
  • MAKEOPTS="-j2"
  • No USE flags are enabled, I left that to you

ROS:

  • kinetic, installed in /opt/ros/kinetic
  • workspace in ~/catkin_ws

Usage:

Not much needs to be adjusted (woot). you’ll need to set up the wifi, however.

User/Password:

  • username is “turtlebot”
  • password is “turtlebot”
  • root password is also “turtlebot”
  • You may consider emerging sudo, if you want.

Wireless:

Edit the file /etc/wpa_supplicant/wpa_supplicant.conf as needed.

ctrl_interface=/run/wpa_supplicant
update_config=1

network={
	ssid="network ssid"
	psk="super secret password"
}

After the wireless is established, you should be able to ssh to the host burger.local.

ROS Setup:

The only thing to change here (as usual) is the ROS_MASTER_URI. Just change this value, and you should be good to go!

What’s Enabled?

  • I know for a fact that the wireless is working.
  • All turtlebot3 packages
  • 64-bit mode
  • Video acceleration (though, if you want to install a desktop, you should remove the line that says gpu_mem in the /boot/config.txt file.

Note: I have not tried anything with bluetooth, so I would not assume it is functioning.

Let me know if you run into any issues! This is certainly not restricted only to turtlebot3 people – you can install most packages now through portage.

1 Like