ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org

Did kinetic support novatel gps

Hi,
Did anyone use kinetic for novatel gps, thanks

Hello! I have primarily tested the novatel-gps-driver package on Indigo and Kinetic, actually. We (at Southwest Research Institute) have been using it internally for a few years now and just released it as open source and pushed it to the build farm for the first time, so it hasn’t made it into the release repository yet. I am planning to make a release announcement sometime soon but hadn’t gotten around to it yet.

Hi, could you give me the debug one, I can test it, thanks

Source code and documentation are available here: https://github.com/swri-robotics/novatel_gps_driver

Thanks, preed
I got this link, but I’am a little confused about your instruction such as catkin init it did not find this command and git clone address should be added as novatel_gps_driver!
Thanks
Sincerely

发自我的 iPhone

Oops, you’re correct. I’ll fix the URL.

I typically use catkin_tools to build catkin packages and am so used to it that I didn’t even think to mention it. You should also be able to use catkin_make to build it like any other catkin workspace.

Hi, Preed,
I used catkin_tools, but it said that:
Errors << novatel_gps_driver:cmake /home/robot/novatel/logs/novatel_gps_driver/build.cmake.002.log
CMake Error at /home/robot/Documents/ros/devel/share/tf2_ros/cmake/tf2_rosConfig.cmake:106 (message):
Project ‘tf2_ros’ specifies
’/home/xiaoqiang/Documents/ros/src/geometry2/tf2_ros/include’ as an include
dir, which is not found. It does neither exist as an absolute directory
nor in
’/home/xiaoqiang/Documents/ros/src/geometry2/tf2_ros//home/xiaoqiang/Documents/ros/src/geometry2/tf2_ros/include’.
Ask the maintainer ‘Tully Foote <tfoote@@osrfoundation.org>’ to fix it.
Call Stack (most recent call first):
/opt/ros/jade/share/tf/cmake/tfConfig.cmake:165 (find_package)
/opt/ros/jade/share/catkin/cmake/catkinConfig.cmake:76 (find_package)
CMakeLists.txt:27 (find_package)
Have you got this problem? Thanks

preed
September 6 |

Oops, you’re correct. I’ll fix the URL.

I typically use catkin_tools to build catkin packages and am so used to it that I didn’t even think to mention it. You should also be able to use catkin_make to build it like any other catkin workspace.

Visit Topic or reply to this email to respond.

In Reply To

wenlong
September 6 |
Thanks, preed I got this link, but I’am a little confused about your instruction such as catkin init it did not find this command and git clone address should be added as novatel_gps_driver! Thanks Sincerely 发自我的 iPhone

Visit Topic or reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here.

I haven’t seen errors like that before. Those look a little strange; are you able to compile other catkin packages from source without problem? Have you tried using catkin_make to compile novatel-gps-driver instead?

Although, I also see this:

Call Stack (most recent call first):
/opt/ros/jade/share/tf/cmake/tfConfig.cmake:165 (find_package)
/opt/ros/jade/share/catkin/cmake/catkinConfig.cmake:76 (find_package)

If you are using ROS Jade, novatel-gps-driver has actually already made it into its release repository, so you may be able to simply do sudo apt-get install ros-jade-novatel-gps-driver and skip compiling it from source.

Dear preed
I solved this problem, for the name of virtual machine
Does this project support OEM718D?
I launched and it always said that insufficient data rate
The frequency is 5Hz, thanks
Sincerely

preed
September 8 |

I haven’t seen errors like that before. Those look a little strange; are you able to compile other catkin packages from source without problem? Have you tried using catkin_make to compile novatel-gps-driver instead?

Although, I also see this:

Call Stack (most recent call first):
/opt/ros/jade/share/tf/cmake/tfConfig.cmake:165 (find_package)
/opt/ros/jade/share/catkin/cmake/catkinConfig.cmake:76 (find_package)

If you are using ROS Jade, novatel-gps-driver has actually already made it into its release repository, so you may be able to simply do sudo apt-get install ros-jade-novatel-gps-driver and skip compiling it from source.

Visit Topic or reply to this email to respond.

In Reply To

wenlong
September 8 |
Hi, Preed, I used catkin_tools, but it said that: Errors << novatel_gps_driver:cmake /home/robot/novatel/logs/novatel_gps_driver/build.cmake.002.log CMake Error at /home/robot/Documents/ros/devel/share/tf2_ros/cmake/tf2_rosConfig.cmake:106 (message): Project ‘tf2_ros’ specifies ’/home/xiaoq…

Visit Topic or reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here.

Dear preed
I got this problem
rostopic echo /bestpos
ERROR: Cannot load message class for [novatel_gps_msgs/NovatelPosition]. Are your messages built?
I did source devel/setup.bash before
Thanks

preed
September 8 |

I haven’t seen errors like that before. Those look a little strange; are you able to compile other catkin packages from source without problem? Have you tried using catkin_make to compile novatel-gps-driver instead?

Although, I also see this:

Call Stack (most recent call first):
/opt/ros/jade/share/tf/cmake/tfConfig.cmake:165 (find_package)
/opt/ros/jade/share/catkin/cmake/catkinConfig.cmake:76 (find_package)

If you are using ROS Jade, novatel-gps-driver has actually already made it into its release repository, so you may be able to simply do sudo apt-get install ros-jade-novatel-gps-driver and skip compiling it from source.

Visit Topic or reply to this email to respond.

In Reply To

wenlong
September 8 |
Hi, Preed, I used catkin_tools, but it said that: Errors << novatel_gps_driver:cmake /home/robot/novatel/logs/novatel_gps_driver/build.cmake.002.log CMake Error at /home/robot/Documents/ros/devel/share/tf2_ros/cmake/tf2_rosConfig.cmake:106 (message): Project ‘tf2_ros’ specifies ’/home/xiaoq…

Visit Topic or reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here.

I haven’t tested the driver with an OEM718D, but I think it should work. Make sure you set the polling_period param correctly; I believe the default is 0.05, but if your GPS is running at 5 Hz, then it should be 0.20.

Actually, I think there may be a bug that causes the “insufficient data rate” warning to be logged if your GPS produces GPGGA logs at a rate less than 20 Hz, even if your polling_period is configured differently. I’ll look into that. If it is working properly, you should see it publish gps_common/GPSFix messages on the gps topic at your expected rate.

As for your other problem, are you sure you sourced ROS’s setup.bash in the same terminal you ran rosecho in after you installed the packages? I tested it on a fresh Ubuntu 14.04 / ROS Jade system, and running rosmsg show novatel_gps_msgs/NovatelPosition worked for me.

@wenlong Please reask this as a question on http://answers.ros.org following our Support Guidelines.

We work to keep the release category here on ROS Discourse for announcements and packaging related discussions.

You can link to it from here so others who find this thread will find your question. (If you edit your above post it won’t resend emails to everyone.)

Hi, Reed
I changed the GPGGA log rate to 20Hz, but the “insufficient data rate” warning did appear again