ROS GUI on MacBook Air (M1 chip)

Hello everyone my name is Surafel first time posting here. I am from Ethiopia. I have been using ROS on an old laptop and now I bought mac m1. I installed ROS1 using docker and it works fine. However, I am having issue running the GUI tools (Rviz and Gazebo). Any kind of help is appreciated.

Welcome to ROS discourse, Surafel.

Questions for help like that are better asked on https://answers.ros.org/questions/, you’ll get more responses there. When posting there I’d also recommend adding more detail, such as what you’ve already tried and what errors, if any, you are getting.

@chfritz thanks for the reply. I have tried using this guide https://roboticseabass.com/2021/04/21/docker-and-ros/

the error that I am getting is qt.qpa.xcb: could not connect to display

qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.

This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.

qemu: uncaugh

Your issue doesn’t seem to be related to ROS, but to X-forwarding from inside a docker container. But like I said, please post this on answers.ros.org, or on StackOverflow. On the latter your problem will probably be solved in a matter of minutes.

1 Like

maybe this link could help you. http://wiki.ros.org/es/docker/Tutorials/GUI

hi Surafel,

I also own a mac with m1 and installing ROS and and dependencies from source is a nightmare. I tried in the past some virtual machines like VirtualBox and their performance was terrible.
I heard about parallels, a virtual machine for Mac and I got surprised on how well ros2 Is working under Ubuntu. I was sceptical about running GUIs and visualizations, but Gazebo and RVIZ are surprisingly working perfectly for me. Give it a try!

I would recommend having a look at the excellent RoboStack repo that aims to leverage conda-forge for deployment of pre-compiled ROS packages under Linux (intel, arm), Windows, MacOS (intel, arm). Currently they serve noetic and humble packages that include visualisation and simulation (ex. I use noetic on MacOS). If you have any issues, the folks behind the repo are very helpful.

1 Like

I would run it in a Parallels VM, if you really need to be on your Mac. Parallels takes care of the arcane setup procedures for graphics drivers and everything else. It saves a lot more time than its price, if running ROS on Mac is really what you need to do.

I would double check that you actually want to develop in a VM on your Mac. I ran this two-arm assembly project in a Docker container on a Mac with Parallels for presentations and classes. But I did not develop in it, because the different hotkeys got in the way too much. A native Ubuntu install is definitely preferable.

I think there is an option to access Desktop via VNC.
There is a Dockerfile, using that would be one option.

1 Like