MoveIt Setup assistant for ROS 2

Hi everyone,
i am currently dealing with a simple pick and place operation and i do not have any issues.
I would like to integrate my robot (practically substitute panda), a comau racer 5.8. I’ve consulted all robots available and it does not appear in the list.
So now i would like to integrate with my URDF and SRDF description, in MoveIt tutorial i discovered that Moveit gives a moveit setup assistant to automatically produce config file… But i am not sure this tools is available or correct for ROS2 usage.
Hope someone more confident than me!


The moveit setup assistant is supported in ROS2 (MoveIt Setup Assistant - Merge the Feature branch by DLu · Pull Request #1254 · ros-planning/moveit2 · GitHub), take a look at MoveIt Setup Assistant — MoveIt Documentation: Humble documentation

Please let me know if you run into any issues!


Just to be extra pedantic - the setup assistant is available in ROS2 Humble - it’s not yet backported in any earlier ROS2 version (although there are some PRs working on back port to Foxy)

1 Like

The documentation for humble seems to be a copy paste from noetic without any changes. Is there ros2 docs somewhere?

1 Like

I think you are right, need to install noetic and run it in parallel.

If you generate moveit config files in ROS 1 they are incompatible with ROS 2.

Maybe I misunderstood, and you think to run MoveIt on Noetic in parallel.

Still, if you can use docker you could generate configuration with Humble and then use it for Foxy. I don’t know on top of my head, but he changes should not be huge.

I’m not 100% sure that Foxy will load the configuration correctly (yet). There were some changes/fixes to the moveit_config_builder stuff, and I don’t know if that has been backported to Foxy (there were/are several PRs - not sure of their status).

As for documentation - the workflow is pretty similar to ROS1 (actually launching the setup tool obviously requires a different command since roslaunch is replaced by the ros2 command - but once you get the GUI up and go through the steps, the actual screens should look very similar to ROS1).


Hello , I am just trying to get MoveIt2 setup assistance ( MSA) to run but not a lot information around how to start although it should have been implemented (ported ) to ros2 humble now. Trying to execute

ros2 launch moveit_setup_assistant setup_assistant.launch
returns :

file ‘setup_assistant.launch’ was not found in the share directory of package ‘moveit_setup_assistant’ which is at ‘/home/micha/ws_moveit2/install/moveit_setup_assistant/share/moveit_setup_assistant’

command must be: ros2 launch moveit_setup_assistant

Then it is running, but crashes when trying to load any urdf.xacro files or so. may be anybody was successful already? then please let me know…

I have the same problem. I have opened an issue and I am waiting. Write in the issue so I know I’m not the only one with the problem

I first had to source the environment of the xacro urdf I was loading in. I’m not sure why this would be a problem but it worked for me.

Hello, is that true? Have you installed noetic parallel to your ROS2 distribution to get the MSA running?
Best, Hans

I am running in the same problem on my ROS2 Humble distribution on ubuntu 22.04… Has someone got any solution for that? Thanks, Hans

edit: when i copy paste my urdf-file location manually in the MSA it quits instantly and prompt following error code
[ERROR] [1677509263.600254160] [moveit_rdf_loader.rdf_loader]: File does not exist

Does not help me out, but maybe it helps some of you?

The MSA for ROS1/ROS2 are completely separate - and the launch files generated are VERY different. So having noetic installed will have no impact (positive nor negative) for running MSA in ROS2.

The URDF needs to be within a ROS2 package that is on your path - it’s a (recently) known issue that hasn’t been solved yet: MoveIt Setup Assistant crashes when URDF is invalid path or not on ROS2 path · Issue #1944 · ros-planning/moveit2 · GitHub