ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org

New PCA9685 driver for ROS

Hey dheera,

i set the address Parameter to 96 and it worked. Now i can start the node.
Only thing that still doesn´t work is the “move” command:
rostopic pub /pca9685_node/command std_msgs/Int32MultiArray “ {data: [-1, -1, -1, -1, -1, -1, -1, -1, 32767, 65535, 0, -1, -1, -1, -1, -1]}”

i can run it and then it Displays me : Publishing and latching message
… but still no motor reacts.
The pin layout is exactly the same like in the c programm i used. So i tryed to use the rqt_graph to maybe find the mistake (i litterly just started using ros). It shows me this Picture:
rosgraph
Shouldn`t there only be one node running?

Thank you for your fast help and your Patience with me :smiley:

Hi,
Can you verify that you actually launched the node in the “/pca9685_node” namespace? Topics don’t get namespaced unless you specify one with e.g. ns=“pca9685_node” in the launch file, and even then I would suggest calling it something more human-readable e.g. ns=“pwm_driver”.
Can you do a “rostopic list” and post the output?

The “rostopic” command creates a temporary node of its own so that is normal.

I appreciate that you two are helping each other out, that’s great, but perhaps it is better done via DM, or on answers.ros.org, or on git issue. When you use discourse everyone to has ever commented on the thread gets and e-mail. :smiley:

1 Like

Hi,
thank you for the advise Katherine. I made a Question on answers.ros.org so that you won`t get any more emails from now on :smiley:
Here is the link:
https://answers.ros.org/question/354759/how-to-publish-to-pca9685-driver-by-dheera/

rostopic pub /command std_msgs/Int32MultiArray “{data: [32767, 0, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1]}”